diff CMakeLists.txt @ 188:c71d879e18cd

version: use the version from cmake files if needed If we fail to get version info from hg, fall back to using the version number from the top-level CMakeLists.txt. Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
author Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
date Sat, 15 Apr 2017 18:01:39 -0400
parents f89655d2e205
children 53fd6f9605de
line wrap: on
line diff
--- a/CMakeLists.txt	Sat Apr 15 18:00:09 2017 -0400
+++ b/CMakeLists.txt	Sat Apr 15 18:01:39 2017 -0400
@@ -144,6 +144,7 @@
 	COMMAND ${CMAKE_COMMAND}
 		-DSOURCE_DIR=${CMAKE_CURRENT_SOURCE_DIR}
 		-DBINARY_DIR=${CMAKE_CURRENT_BINARY_DIR}
+		-DJEFFPC_VERSION=v${JEFFPC_VERSION}
 		-P ${CMAKE_CURRENT_SOURCE_DIR}/cmake/hg.cmake
 )