diff CMakeLists.txt @ 262:89bf89fc814c

nvlist: introduce a name-value list API This commit introduces a new name-value list data structures and API. Each name is always a string, and each value is one of: - blob - bool - int - null - nvlist - refcounted immutable string (struct str) Additionally, the value can also be an array consisting of members of any of the above type. (Much like Python lists or JSON arrays, the elements of an array do not have to be of the same type.) Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
author Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
date Fri, 07 Jul 2017 21:25:29 +0300
parents d9e1019ba9d0
children 6cc52ba25b46
line wrap: on
line diff
--- a/CMakeLists.txt	Tue Jul 11 00:39:14 2017 +0300
+++ b/CMakeLists.txt	Fri Jul 07 21:25:29 2017 +0300
@@ -92,6 +92,8 @@
 	init.c
 	io.c
 	list.c
+	nvl.c
+	nvl_dump.c
 	padding.c
 	rand.c
 	sexpr.c
@@ -128,6 +130,7 @@
 		include/jeffpc/jeffpc.h
 		include/jeffpc/list.h
 		include/jeffpc/mem.h
+		include/jeffpc/nvl.h
 		include/jeffpc/padding.h
 		include/jeffpc/rand.h
 		include/jeffpc/refcnt.h
@@ -185,6 +188,7 @@
 build_test_bin_and_run(errno)
 build_test_bin_and_run(hexdump)
 build_test_bin_and_run(list)
+build_test_bin_and_run(nvl)
 build_test_bin_and_run(padding)
 build_test_bin_and_run(sexpr_eval)
 build_test_bin_and_run(version)