diff CMakeLists.txt @ 141:08416c57f077

sexpr: implement a simple REPL for the sexpr APIs It turns out this little utility is really helpful when it comes to finding bugs. Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
author Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
date Mon, 10 Apr 2017 16:51:25 -0400
parents aa39202a5963
children 2350f0436f22
line wrap: on
line diff
--- a/CMakeLists.txt	Sun Apr 09 23:19:58 2017 -0400
+++ b/CMakeLists.txt	Mon Apr 10 16:51:25 2017 -0400
@@ -145,6 +145,19 @@
 add_dependencies(jeffpc revisiontag)
 
 #
+# REPL executable
+#
+
+add_executable(sexpr-repl EXCLUDE_FROM_ALL
+	repl.c
+)
+
+target_link_libraries(sexpr-repl
+	tecla
+	jeffpc
+)
+
+#
 # Test related executables
 #