view contrib/mercurial.spec @ 563:42a6a41ab76b

[PATCH] clean up RPM spec file -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 [PATCH] clean up RPM spec file From: Bryan O'Sullivan <bos@serpentine.com> The current RPM spec file makes it impossible to split Mercurial into multiple interdependent packages. Here's a patch that fixes that problem. manifest hash: 4acc4c5cf4485d92a32d2259b83314b7167dece3 -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.0 (GNU/Linux) iD8DBQFCxb2+ywK+sNU5EO8RAnrTAJ4tkAh6xnHvRHMxzrfqKb/SXYS2wwCeMfK1 PAr+1FFoSqUmA9rt8Yaw6f4= =MaPn -----END PGP SIGNATURE-----
author mpm@selenic.com
date Fri, 01 Jul 2005 14:03:42 -0800
parents 7c1952b29656
children ab22af71386f
line wrap: on
line source

Summary: Mercurial -- a distributed SCM
Name: mercurial
Version: 0.6
Release: 1
Copyright: GPL
Group: Development/Tools
Distribution: RedHat
Source: http://www.selenic.com/mercurial/release/%{name}-%{version}.tar.gz
Packager: Arun Sharma <arun@sharma-home.net>
Prefix: /usr
BuildRoot: /tmp/build.%{name}-%{version}-%{release}

%define pythonver %(python -c 'import sys;print ".".join(map(str, sys.version_info[:2]))')
%define pythonlib %{_libdir}/python%{pythonver}/site-packages/%{name}

%description

Mercurial is a fast, lightweight source control management system designed
for efficient handling of very large distributed projects.

%prep

rm -rf $RPM_BUILD_ROOT

%setup -q -n %{name}-%{version}

%build

python setup.py build

%install

python setup.py install --root $RPM_BUILD_ROOT

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root,-)
%doc doc
%dir %{pythonlib}
%{_bindir}/hgmerge
%{_bindir}/hg
%{pythonlib}/templates
%{pythonlib}/*.pyc
%{pythonlib}/*.py
%{pythonlib}/*.so